
Experiment 3: Modeling, Identi¯cation,

and Control of a DC-Servomotor

Concepts emphasized: Dynamic modeling, time-domain analysis, system identi¯cation, and

position-plus-velocity feedback control.

1. Introduction

DC-motors that are used in feedback controlled devices are called DC-servomotors [1{4]. Appli-

cations of DC-servomotors abound, e.g., in robotics, computer disk drives, printers, aircraft °ight

control systems, machine tools, °exible manufacturing systems, automatic steering control, etc.

DC-motors are classi¯ed as armature controlled DC-motors and ¯eld controlled DC-motors [4].

This laboratory experiment will focus on the modeling, identi¯cation, and position control of an

armature controlled DC-servomotor. In particular, we will ¯rst develop the governing di®erential

equations and the Laplace domain transfer function model of an armature controlled DC-motor.

Next, we will focus on the identi¯cation of the unknown system parameters that appear in the

transfer function model of the DC-servomotor. Finally, we will develop and implement a position-

plus-velocity, also known as proportional-plus-derivative (PD), feedback controller to ensure that

the DC-motor angular position response tracks a step command.

2. Background

DC-motor modeling: A schematic representation of an armature controlled DC-motor is

given in Figure 1. For an armature controlled DC-motor, the ¯eld current if is constant and the

torque Tm generated at the DC-motor shaft is given by [2{4]

Tm = KTia; (2.1)

where KT is the given motor torque constant (N-m/Amp) and ia is the armature current (Amp).

Note that for an armature controlled DC-motor, the back e.m.f. induced in the armature due

to armature rotation is directly proportional to the armature angular velocity !m(t)
4
=
dµm
dt where

µm(t) is the angular position of the motor shaft. Thus, following [2{4]

Vb = Kb

dµm
dt
; (2.2)
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where Kb is a given motor constant (Volt-sec/rad).

Figure 1: Armature Controlled DC-Motor

Next, note that the angular speed !m(t) of an armature controlled DC-motor is controlled by

the armature voltage Va. The di®erential equation relating the armature current ia and the back

e.m.f. Vb to the armature voltage Va can be obtained by applying Kirchho®'s Voltage Law [1, 4].

In particular, according to the Kirchho®'s Voltage Law, at any given instant of time, the algebraic

sum of voltages around any loop in any electric network is zero. Thus, a direct application of the

Kirchho®'s Voltage Law to the armature circuit yields

La
dia
dt
+Raia + Vb = Va: (2.3)

Finally, we obtain the di®erential equation governing the motion of the mechanical load. First,

note that in most applications, the DC-servomotor shaft is connected to a gear-box of a given

gear-ratio Kg and the load is attached to the output shaft of the gear-box (e.g., see Figure 2). The

gear-ratio Kg is give by Kg
4
=

n`
nm
, where n` and nm are the number of teeth on the load-side and

the motor-side gears, respectively. It can be easily shown that the gear-ratio Kg relates the motor

shaft angular position µm to the gear-box output shaft angular position µ` by Kg =
µm
µ`
. In addition,

it can be shown that the load inertia J` acting at the output shaft of the gear-box when re°ected

at the motor shaft is given by 1
K2
g
J`. Thus, an application of Newton's moment balance equation

at the motor output shaft yields

Jm
d2µm
dt2

+
1

K2
g

J`
d2µm
dt2

+
1

K2
g

bt
dµm
dt

= Tm;
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which can be rewritten as

Jeq
d2µ`
dt2

+ bt
dµ`
dt

= KgTm; (2.4)

where Jeq = K
2
gJm+ J` is the total load inertia re°ected at the motor shaft and bt is the rotational

viscous friction constant.

Figure 2: DC-Motor Experiment Test-Bed

Now, taking the Laplace transform of (2.1){(2.4) and after some algebraic manipulations to

eliminate the variables Tm, Vb, and ia , we obtain

µ`(s)

Va(s)
=

KgKT

s
³
LaJeqs2 + (Labt +RaJeq)s+Rabt +K2

gKTKb

´ : (2.5)

In addition, the transfer function from input Va to output !` is given by

!`(s)

Va(s)
=

KgKT

LaJeqs2 + (Labt +RaJeq)s+Rabt +K2
gKTKb

: (2.6)

Now, assuming two real, simple roots of the characteristic equation of (2.6), viz., pe and pm, partial

fraction expansion of (2.6) yields

!`(s)

Va(s)
=

Ke

s+ pe
+

Km

s+ pm
: (2.7)

Next, using the inverse Laplace transform, the forced response of the system (with zero initial

condition) to the input Va(t) is given by

!`(t) =

Z t

0

h
Kee

¡pe(t¡q) +Kme
¡pm(t¡q)

i
Va(q)dq: (2.8)

In most practical applications of armature controlled DC-motors, pe >> pm; i.e., the electrical

subsystem responds considerably faster than the mechanical subsystem. Hence, the ¯rst exponential
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term in (2.8) decays rapidly. Thus, the response !`(t) in (2.8) is dominated by the mechanical

subsystem Km
s+pm

. For simplicity, in DC-servomotor control applications the in°uence of the electrical

subsystem component ( Kes+pe
) on the response !`(t) in (2.8) is commonly neglected [2{4]. This can

alternatively be viewed as neglecting the armature inductance e®ect, La. This simpli¯cation yields

a ¯rst-order transfer function model which relates the DC-motor load angular velocity response !`

to the armature voltage input Va, and is given by

!`(s)

Va(s)
=

KgKT

RaJeqs+Rabt +K2
gKTKb

: (2.9)

Before proceeding, note that, it can be shown that in the SI-Units used for KT and Kb, the

numerical values of KT and Kb are identical [3]. Finally, the transfer function model of (2.9) can

be equivalently written as

!`(s)

Va(s)
=

K

¿s+ 1
; (2.10)

whereK and ¿ are the dc-gain and the mechanical time-constant of the DC servomotor, respectively.

3. Objective

i) Analysis of DC-motor sensor characteristics.

ii) DC-motor system identi¯cation.

iii) PD control of the DC-motor to achieve the desired angular position step response charac-

teristics.

4. Equipment List

i) PC with MultiQ-3 data acquisition card and connecting board

ii) Software environment: Windows, Matlab, Simulink, RTW, and WinCon

iii) SRV-02 DC-motor apparatus (See Figure 3) with potentiometer, optical encoder, and

tachometer

iv) Universal power module: UPM-1503

v) Set of leads
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Figure 3: SRV-02 DC-Motor Apparatus

5. Experimental Procedure

i) Using the set of leads, universal power module, SRV-02 DC-motor apparatus, and the

connecting board of the MultiQ-3 data acquisition card, complete the wiring diagram

shown in Figure 4.

ii) Start Matlab and WinCon Server. In the Matlab window, at the command prompt, type

\Experiment3" and hit the Enter key. This Matlab script will change the directory from

the default Matlab directory to the directory where all ¯les needed to perform Experiment

3 are stored.

iii) You can now perform various steps of the DC-motor identi¯cation and control experiment.

However, before proceeding, you must request your laboratory teaching assistant to che-

ck your electrical connections.

iv) From the File menu of the WinCon Server, select the option Open to load the exper-

iment ¯le \Experiment3 Pot.wcp." This will load the ¯les for determining the gain of
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Figure 4: Wiring Diagram for DC-Motor ID and Control

the potentiometer Kpot (
radian
Volt

). A digital meter window will also appear on your desk-

top. The potentiometer gain Kpot relates the potentiometer output voltage Vpot to the

load angular displacement µ` by µ` = KpotVpot. Next, from the Window menu of the

WinCon Server, select the option Simulink. This will load the Simulink block-diagram

\Experiment3 Pot.mdl" shown in Figure 5 to your desktop.

a) In the WinCon Server interface, click the green Start button to acquire the poten-

tiometer voltage response.

b) Rotate the load connected to the output shaft (center gear) until the potentiometer

voltage in the digital meter window shows 0 Volt. Please ensure that you get contin-

uous variation in the neighborhood of this 0 Volt reading. If you note a discontinuity

in the reading, turn the load by 180± and this will provide you close to 0 Volt reading.

Read the angular position µ±0 of the load, corresponding to the 0 Volt potentiometer

reading, o® the protractor marked on the SRV-02 apparatus.
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Figure 5: Simulink Block-Diagram for Determining Potentiometer Gain

c) Rotate the load to µ0+90
± and note the corresponding potentiometer voltage reading

in the digital meter window.

d) Rotate the load to µ0¡90± and note the corresponding potentiometer voltage reading
in the digital meter window.

e) In the WinCon Server interface, click the red Stop button when you ¯nish collecting

the potentiometer voltage response data.

v) Close the currently open digital meter window and the Simulink diagram. From the File

menu of the WinCon Server, select the option Open to load the experiment ¯le \Experi-

ment3 Tach.wcp." This will load the ¯les for determining the gain of the tachometer Ktach

( radian
second-Volt

) and a plot window. The tachometer gain Ktach relates the tachometer output

voltage Vtach to the load angular velocity !` by !` = KtachVtach. Next, from theWindow

menu of the WinCon Server, select the option Simulink which loads the Simulink ¯le

\Experiment3 Tach.mdl" shown in Figure 6 to your desktop.

a) In the WinCon Server interface, click the green Start button. This applies a constant

1 Volt input to the DC-motor.

b) Measure the steady-state load angular speed and the corresponding steady-state

tachometer output voltage reading in the plot window. Hint: Find the time re-
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Figure 6: Simulink Block-Diagram for Determining Tachometer Gain

quired for 20 complete revolutions of the load and the corresponding steady-state

tachometer output voltage reading at the end of 20 revolutions.

c) In the WinCon Server interface, click the red Stop button when you ¯nish collecting

the tachometer voltage response data.

vi) Close the currently open plot windows and the Simulink diagram. From the File menu

of the WinCon Server, select the option Open to load the experiment ¯le \Experi-

ment3 DCID.wcp." Next, from the Window menu of the WinCon Server, select the

option Simulink which loads the Simulink ¯le \Experiment3 DCID.mdl" shown in Fig-

ure 7 to your desktop. In this diagram, the gain Ktach must be supplied by you. Run

this part of the experiment to acquire the transient and steady-state angular velocity step

response of the DC-motor under load.

vii) Close the currently open plot windows and the Simulink diagram. From the File menu

of the WinCon Server, select the option Open to load the experiment ¯le \Experi-

ment3 PDCont.wcp." Next, from the Window menu of the WinCon Server, select the

option Simulink which loads the Simulink ¯le \Experiment3 PDCont.mdl" shown in Fig-

ure 8 to your desktop. In this diagram, the gains Kpot and Ktach must be supplied by you.

In addition, the gains KP and KD must be designed and supplied by you. In particular,

design a PD feedback controller so that the DC-motor angular position step response ex-
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Figure 7: Simulink Block-Diagram for DC-Servomotor System Identi¯cation

hibits a peak overshootMp · 5% with settling time Ts · 1 second. The feedback diagram
of the DC-motor with the PD feedback controller is shown in Figure 9. The characteristic

equation of the closed-loop system in Figure 9 can be used for the purpose of ¯nding KP

and KD such that the desired performance speci¯cations are achieved. Before proceeding,

you must request your laboratory teaching assistant to approve your gain values. Run

the experiment to record the angular position step response of the DC-motor.

6. Analysis

i) Calculate Kpot andKtach from the experimental data collected in steps iv) and v) of Section

5.

ii) Analyze the open-loop angular velocity step response obtained in step vi) of Section 5

to determine the dc-gain K and the mechanical time constant ¿ of the DC-servomotor

system.

iii) Obtain the angular velocity step response of the ¯rst-order system (2.10) with the param-

eters K and ¿ obtained in step ii) above. Compare the simulated angular velocity step

response with the experimental response obtained in step vi) of Section 5 and comment.
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Figure 8: Simulink Block-Diagram for DC-Servomotor PD Control

Figure 9: Closed-Loop Feedback Interconnection for PD Control of a DC-Motor

iv) Analyze the closed-loop angular position step response obtained in step vii) of Section 5

to determine if the performance speci¯cations are satis¯ed. Comment on your results.

v) Design a proportional-integral-derivative (PID) controller so that the performance require-

ments speci¯ed in Section 5 are satis¯ed. Simulate the closed-loop angular position step

response with the PID controller. Compare with the experimental closed-loop angular

position step response obtained using the PD controller.
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